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Preview
A Quick Look at PRO MATE® Development System

What is PRO MATE
Congratulations on selecting the PRO MATE, a Microchip microcontroller 
device programmer. Though interchangeable programming socket modules 
PRO MATE enables you to quickly and easily program the entire line of 
Microchip PICmicro™ microcontroller devices, many of the Microchip memory 
parts, and the KEELOQ® Code Hopping Encoders.

How PRO MATE Helps You
With the PRO MATE device programmer, you can program Microchip 
microcontroller devices from a PC Host, or you can use the device 
programmer as a stand-alone unit.

• PRO MATE is easy to use and flexible in programming Microchip 
devices and package types.

• PRO MATE will expand to support future Microchip devices always 
providing the latest programming algorithms to support Microchip 
PICmicro microcontroller devices and other Microchip parts, via the 
Microchip Internet Web page and the Microchip BBS.

PRO MATE Connected to a PC
When connected to a PC, PRO MATE provides two levels of control:

MPLAB Windows IDE

Using MPLAB™ Integrated Development System as the interface, PRO MATE 
becomes another tool in MPLAB’s integrated development environment (IDE), 
allowing you to quickly compile, test, and debug your firmware, then download 
it into PRO MATE to be programmed in your firmware. 

DOS Command Line Interface

For environments where a Windows interface is not required, PRO MATE can 
perform basic functions, such as download and program firmware, and add 
SQTPSM serialization to firmware.

PRO MATE Operating Without a PC (Stand-Alone)
Without a PC connection to PRO MATE, the unit operates as a stand-alone 
device programmer. The main programmer features of the PRO MATE are 
available, including Read, Program, Verify.
”  1997 Microchip Technology Inc. DS30082G- page 1
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The PRO MATE is CE compliant
The PRO MATE development system is designed, tested and certified to meet 
the Electromagnetic Compatibility requirements known as the CE compliance 
directives. These standards set by the European Union (EU) countries include 
limiting radiated emission, improving susceptibility to radiated emission and 
improving susceptibility to Electrostatic Discharge (ESD).

How PRO MATE Helps You
The PRO MATE device programmer is a device programmer system that has 
the following features:

• Programs PICmicro microcontrollers

• Programs many Microchip Memory parts

• Programs KEELOQ Code Hopping devices

• Operates as a Windows® 3.1 application on a PC with the MPLAB™ 
Integrated Development Environment

• Communicates with the PC via a standard RS-232 cable

• With MPLAB the user can create, display, and edit firmware to be 
programmed into PICmicro microcontrollers and Microchip memory 
devices

The PRO MATE device programmer comes with the following accessories:

• RS-232 Interface cable to a standard PC serial port

• Universal power supply

• MPLAB, an Integrated Development Environment including a text 
editor, project manager, MPASM assembler, and MPLAB-SIM 
debugger 

Note: A complete line of socket modules is available. You may order the 
socket modules separately for the device that you will be 
programming.
DS30082G- page 2 ”  1997 Microchip Technology Inc.
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Chapter 1.   About PRO MATE
Introduction 
This section will present an overview of the PRO MATE device programmer. 
The features and requirements of PRO MATE are presented.

MPLAB Integrated Development Environment
The MPLAB Integrated Development Environment (IDE) is the host software 
for PRO MATE. You will be able to load in your hex files and program with the 
PRO MATE without reading the MPLAB User’s Guide. To take advantage of 
the MPLAB editor, project manager, and built in MPASM support, read the 
MPLAB User’s Guide. With MPLAB-SIM (described in the MPLAB User’s 
Guide) you will be able to test execution of your code and perform most 
debugging functions without an emulator.

PRO MATE Tools
You can set up PRO MATE on any serial communications port on 
your PC.

With PRO MATE you can do the following operations:

• Program memory, configuration bits, ID locations, and calibration data 
into PICmicro devices.

• Verify that PICmicro microcontrollers are blank.

• Verify that code in the target microcontroller matches your firmware.

• Read code from an unprotected PICmicro microcontroller into MPLAB’s 
program memory window for debugging and programming into other 
PICmicro devices.

• Program unique serialized ID numbers into your firmware using SQTP 
(Serial Quick Turn Programming) files.

• Program many Microchip Memory parts.

• Program KEELOQ Code Hopping devices.

System Requirements
To run in the Windows mode with MPLAB you must have MPLAB installed on 
IBM PC/AT¨ compatible 386 or better with:

• Windows 3.1 with a VGA or better monitor and mouse

• 4 MB of memory, 16 MB recommended

• 8 MB of hard disk space, 20 MB recommended

• Serial port
”  1997 Microchip Technology Inc. DS30082G- page 3
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To run in the DOS command prompt mode or from a DOS Batch file, you must 
have:

• MS-DOS 5.0 or later 

• EGA (or better) monitor

• 1 MB of memory

• 1.44 Megabyte floppy disk drive, 3.5”

• Hard drive

• Serial port

About This Guide
This user guide describes how to use the PRO MATE development 
programmer with MPLAB, the Integrated Development Environment for 
Microchip development tools. The layout of the manual is as follows:

Chapter 1 - About PRO MATE - An overview of the features and benefits of 
the PRO MATE device programmer.

Chapter 2 - PRO MATE Installation - Instructions for installing the PRO 
MATE hardware and software.

Chapter 3 - PRO MATE Basic Functions - An overview of the features of 
PRO MATE, covering all the basic hardware functions, and explaining the 
MPLAB software interface.

Chapter 4 - Using PRO MATE - A walk-through on using PRO MATE in a 
typical application.

Chapter 5.   Stand-Alone Mode - Information on how to program 
microcontroller devices by using the menu options available from the PRO 
MATE device programmer without connecting to the PC.

Chapter 6 - PRO MATE Menu Options - Reference material that covers each 
of the PRO MATE MPLAB menu options, and the basic MPLAB software 
dialogs for PRO MATE.

Chapter 7 - Migrating from Earlier PRO MATE Systems - Information for 
users of previous versions of PRO MATE.

Appendix A - Troubleshooting Guide - A list of solutions for common 
problems.

Appendix B - On Line Support - Information on Microchip’s electronic 
support services.

Appendix C - Programming Microchip Memory Parts - Details on using 
PRO MATE to program Microchip programmable memory devices.

Appendix D - Programming KEELOQ Code Hopping Encoders - Special 
PRO MATE programming capabilities to program Microchip security devices. 

Index - Alphabetical index to PRO MATE User’s Guide

Worldwide Sales and Service - Listing of worldwide Microchip sales offices.
DS30082G- page 4 ”  1997 Microchip Technology Inc.



Chapter 1. About PRO MATE
Recommended Reading
README.PRO  For the latest information on using PRO MATE, read the 
README.PRO file on the installation diskette. The README.PRO file 
contains update information that may not be included in this manual.

PICmicro Microcontroller Data Book  Contains comprehensive data sheets 
for Microchip PICmicro microcontroller devices available at print time. 
Document Number DS00158, Microchip Technology Inc., Chandler, AZ.

Embedded Control Handbook  Contains a wealth of information about 
microcontroller applications. The application notes described in this manual 
are also available electronically through the Microchip BBS or from the 
Microchip Internet Home Page (see Appendix B: On-Line Support, for 
information). Document Number DS00092, Microchip Technology Inc., 
Chandler, AZ.

MPLAB User’s Guide  Comprehensive guide that describes installation and 
features of Microchip’s MPLAB, Integrated Development Environment, as well 
as the editor and simulator functions in the MPLAB environment. Document 
Number DS30421, Microchip Technology Inc., Chandler, AZ.

PRO MATE/PRO MATE ll Device Support  A document which lists the part 
numbers for the socket modules that support each device, discusses the life 
expectancy and cleaning procedures for the different socket types, and 
documents specific MPLAB details. Document Number DS51110, Microchip 
Technology Inc., Chandler, AZ.

Warranty Registration
Upon receiving the software diskettes, complete the enclosed Warranty 
Registration Card and mail it promptly. Sending in your Warranty Registration 
Card will ensure that you receive new product updates and notification of 
interim software releases that may become available.

Customer Support
Microchip endeavors at all times to provide the best service and 
responsiveness possible to its customers. Technical support questions should 
first be directed to your distributor and representative, local sales office, Field 
Application Engineer (FAE), or Corporate Applications Engineer (CAE). 

The Microchip Internet Home Page can provide you with technical information, 
application notes, and promotional news on Microchip products and 
technology. The Microchip Web address is http://www.microchip.com.

You can also check with the Microchip BBS (Bulletin Board System) for 
non-urgent support, customer forums, and the latest revisions of Microchip 
systems development products. Refer to Appendix B: On-Line Support, for 
access information. 
”  1997 Microchip Technology Inc. DS30082G- page 5
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Chapter 2.   PRO MATE Installation
Introduction
When running under Windows, the PRO MATE development system requires 
the installation of MPLAB IDE software as well as connecting the hardware to 
the PC. This chapter covers the details of both software and hardware set up, 
including serial port configuration, processor selection, and enabling the 
PRO MATE from MPLAB.

PRO MATE Setup

Installing PRO MATE Hardware
PRO MATE provides communications with the host PC via an RS-232 
9-pin D type connector. PRO MATE is DCE (data communication equipment), 
and hardware handshaking is via CTS (clear to send) and RTS (request to 
send). 

Check your PC set up to see which communications port is available. Usually 
a mouse device is connected to COM1 or COM2. If you have a modem, you 
may not have a third serial port on your PC. 

Connect the cable from your COM port to the PRO MATE development 
programmer.

A 6-foot data cable with DB-9 connectors is supplied with PRO MATE. All lines 
on the data cable are wired straight through. This cable is NOT a null modem 
cable.

PRO MATE Power Supply
The PRO MATE device programmer requires +5 Volts ±5% at 750 mA on the 
5-pin DIN connector (5VDC IN). Pin 3 is +5 Volts, pins 1, 2, and 4 are ground, 
and pin 5 is not connected.

Figure 2.1:   Back of PRO MATE

1

2

3

45
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The PRO MATE II requires +9 volts at 750 mA. The power connector is a 
2.5mm DC power jack (Switchcraft P/N RAPC-712).  A 0.75A fuse (Littlefuse 
Nano2Smf, P/N 451.750) is located near the +9V input on the PRO MATE II 
motherboard for circuit protection.

Figure 2.2:  Back of PRO MATE II

Plug the power supply into a power socket and connect the power supply 
cable to the PRO MATE.

Socket Modules
Interchangeable socket modules allow you to use the device programmer for 
all PICmicro devices. For details about the available socket modules, refer to 
the PRO MATE Device Support document. Refer to the documentation 
enclosed with the socket module for special requirements in programming 
devices with a specific socket module.

Changing Socket Modules     

Tighten the socket-module thumbscrews evenly and, if possible, 
simultaneously. Avoid overtightening them; they should be finger-tight only. To 
remove the socket modules, simply unscrew the thumbscrews.

Socket Module Alignment

After tightening the socket module screws, apply power to the device 
programmer. If the LCD display shows any of the following messages, turn off 
power to the device programmer and realign the socket module:

– Align Socket Bottom
– Align Socket Top
– Select Socket
– Socket Not Known

After changing a socket, insert a blank device and use the device programmer 
Verify command to perform a blank check on the device programmer to ensure 
the socket is making proper contact. A blank device shows erased.

Ordering Socket Modules

Socket modules do not come with the device programmer. You must order 
your socket module(s) separately. Socket modules are available to 
accommodate each device package. Microchip Technology Inc. Development 
System Ordering Guide (DS30177) describes the available socket modules.

+9V

GND

Caution:Ensure that 
the device 
programmer is 
powered OFF before 
changing socket 
modules.

Caution:The gold 
connector strips on 
PRO MATE are 
relatively fragile. 
Avoid touching them 
with the socket 
module screws, and 
avoid over-
tightening the 
screws.
DS30082G- page 8 ”  1997 Microchip Technology Inc.
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Configuring MPLAB for PRO MATE
You should install the MPLAB software by following the instructions in the 
MPLAB User’s Guide. This is a brief summary:

• Insert MPLAB installation diskette 1 into drive A:

• From the Program Manager Run option, type A:Setup.

• Follow the on-screen instructions and install MPLAB

Installing PRO MATE Software for MPLAB

The PRO MATE software is included in the MPLAB installation. To install 
PRO MATE, either select the full MPLAB installation or select custom 
installation and check the checkbox for PRO MATE.

Configuring Serial Port for PRO MATE
If you are not already running the MPLAB software, double click on the 
MPLAB icon now to start. From the Options menu, select 
Options>Programmer Options>Communications Port Setup.

Figure 2.3:  Communications Port Setup Dialog

The Communications Port Setup Dialog shows the possible PC serial 
communication ports. OK sets the communications port. Cancel will ignore the 
change and close the dialog.

Installing PRO MATE Software for DOS
Insert PRO MATE diskette into drive A:

• From the Program Manager Run option, type A:Install.

• Follow the on-screen instructions to install PRO MATE DOS command 
mode software onto your hard disk drive.
”  1997 Microchip Technology Inc. DS30082G- page 9
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Chapter 3.   PRO MATE Basic Functions
Introduction
This chapter describes the basic functions of the PRO MATE development 
system. Once the hardware and software are installed as described in 
Chapter 2: PRO MATE Installation, the various functions of PRO MATE can 
be used as described here. Chapter 4: Using PRO MATE provides a quick 
sample session using PRO MATE.

Highlights
This chapter covers

• Enabling the PRO MATE

• The PRO MATE Programmer Status Dialog 

• Programming a Microcontroller Device

• Verifying a Microcontroller Device

• Checking for a Blank Device

• Reading a Device Master

• Running PRO MATE from the DOS Command Line

• Upgrading PRO MATE Firmware and Host Software

• Files Used by PRO MATE 
”  1997 Microchip Technology Inc. DS30082G- page 11
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Enabling the PRO MATE
If a programmer other than PRO MATE is specified on the menu bar, change 
programmers by selecting Options>Programmer Options>Select 
Programmer. Select PRO MATE from the pull-down list and click OK. MPLAB 
must terminate and be restarted to use the new selection.

Figure 3.1:  Select Programmer Dialog

To enable PRO MATE, select the PRO MATE pull down menu and click 
Enable Programmer to establish communications with PRO MATE. Once the 
programmer is enabled, this menu will show “Disable Programmer” and can be 
used to disable PRO MATE.

Figure 3.2:  PRO MATE Pull Down Menu
DS30082G- page 12 ”  1997 Microchip Technology Inc.
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The PRO MATE Program Status Dialog
The Programmer Status dialog is shown on the screen whenever the 
PRO MATE is enabled. This dialog displays the current setting of the 
configuration bits for the target microcontroller. 

Figure 3.3:   Programmer Status Dialog

The options on the screen will show the current values if active, or will be 
disabled. Depending upon which processor you are currently configured for, 
these items will be enabled or grayed out. 

From this dialog you can set these items (if they are available in your currently 
selected microcontroller):

Device Specifications
• Device - The device type to use with PRO MATE

• Oscillator - Configuration bits for the oscillator mode

• Watch Dog Timer - WDT configuration bit.

• Processor Mode - PIC17CXX family processor mode

• Brown Out Detect - Configuration bits that enable brown out detection
”  1997 Microchip Technology Inc. DS30082G- page 13
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• Code Protect - Code protection configuration bits

• Power Up Timer - Timer power up configuration bits

• Master Clear - Master Clear Enable configuration bits

• Parity- Parity Enable configuration bits

ID’s and Checksum
Pressing the Set ID button on the Programmer Status dialog will pop up the 
Edit ID Dialog.

Figure 3.4:  Edit ID Dialog

If a particular ID value is to be programmed, check the user Entry box and 
enter the 4-digit hex value for the ID. Click on Unprotected Checksum to 
have the non code protected checksum automatically programmed into the 
device. OK sets the option, Cancel cancels the screen and returns to the 
Programmer Status dialog.

The Checksum field displays the checksum of a part. The checksum is not 
selectable and updates automatically.

SQTPSM File — Serialized Quick Turn Program
Click the SQTP File button to enable or disable serial programming. The box 
next to the SQTP button will display the SQTP file. To enable SQTP, click 
SQTP File and select a file from the displayed dialog box. To disable SQTP, 
click SQTP File and select Cancel in the displayed dialog box. 

Refer to “Using Serial Programming” in Chapter 4: Using PRO MATE for a list 
of the steps required to use serial programming.

Program Statistics
The Program Statistics area in the dialog will record the total number of Pass 
and Fail trials as you are programming a series of devices. Press the Reset 
button to set all counts to zero. Program Statistics are updated after 
programming each device. 
DS30082G- page 14 ”  1997 Microchip Technology Inc.
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PASS

The number of devices passing.

FAIL

The number of devices failing.

TOTAL

The number of devices programmed.

Reset

Sets the Program Statistics Counters to zero.

Voltages
The voltage settings allow you to change the voltages used in programming 
and verifying microcontroller devices. Voltages can be adjusted in 0.25 volt 
increments.

VDD Min and VDD Max — Blank Check/Verification Voltages

Click VDD Max or VDD Min to select the VDD maximum or minimum values. 
VDD Min must not be greater than VDD Max, or you will receive an error 
message. The pull-down lists display the allowable VDD range for the selected 
device. Granularity is 0.25 volts. The default values for VDD Max and VDD Min 
are device specific. Refer to the PRO MATE Device Support document for 
details.

VPP — Programming Voltage

Click VPP to select the VPP value. The pull-down list displays the allowable VPP 
range, which is device specific. Refer to the PRO MATE Device Support 
document for details.

Programmer Function Buttons
The Blank, Read, Program, and Verify buttons provide one-click access to the 
common functions of blank checking, reading, programming, and verifying a 
device. Using these buttons will perform the indicated function on the entire 
device. To access only specific areas of the device, use the pull-down menu.

Initializing the Attached Socket Module
If a socket module attached to the device programmer is supported, the 
PRO MATE firmware executes the initialization routine provided for that 
socket module. If the PRO MATE firmware can not recognize an installed 
socket module, the firmware displays a message “Socket Not Supported.”

Upon completing initialization, the MPLAB looks to see which socket module is 
attached to the device programmer. MPLAB will not connect to the device 
programmer until after a socket module is correctly attached to PRO MATE. 

How the Device 
Programmer Uses 
Voltage Checks

The Device Programmer 
performs its operations 
with VDD set to the 
following voltages:

• Blank checks at VDD 
Min.

• Read operations at 5 
volts 

• Programming at 5 volts

• Verify operations at 
both VDD Min. and 
VDD Max.

Here is why:

Partially erased EPROM 
cells will show erased at 
a higher voltage and not 
erased at a lower voltage. 
For this reason, PRO 
MATE performs a blank 
check at VDD Min. 

An EPROM cell that is 
not fully programmed will 
read correct at lower 
voltages, but not show 
programmed at higher 
voltages. For this reason, 
PRO MATE verifies 
programmed devices at 
VDD Max. 

PRO MATE reads 
devices at 5 volts, the 
nominal voltage at which 
the devices should 
operate.

Check to see if a device 
is fully erased by setting 
the VDD Min value to a 
higher voltage from the 
Setup Window. Then 
perform a blank check to 
see if the device shows 
blank.
”  1997 Microchip Technology Inc. DS30082G- page 15



MPLAB-PRO MATE USER’S GUIDE
Setting Configuration Bits and IDs
Configuration bits can be manually entered from the Programmer Status 
dialog. 

You can also specify the  configuration bit values in your source code. Use the 
_ _CONFIG directive in MPASM to set the configuration bits for the device to 
be programmed. You can also use the _ _IDLOCS directive to set the ID 
locations from MPASM. Each time you rebuild your project or reload your hex 
file, the configuration bits and ID locations will be set according to the values 
from these directives. 

Programming a Microcontroller Device
When you select Program/Verify from the PRO MATE menu, the following 
dialog will be activated:

Figure 3.5:  Program/Verify Dialog 

The Program/Verify Dialog is used to send code to the target device (Program) 
or to check that the data in the current device matches the code in the Program 
Memory window (Verify). For normal programming use the default addresses.

If you do not wish to program all sections of the device, remove the checks 
from the appropriate boxes. Options not available on the currently selected 
processor will be grayed out, and cannot be selected.

When you select Program/Verify, the following sequence is initiated:

1. The PRO MATE checks to see if the device is blank. If the device is not
blank, PRO MATE asks if you want to continue.
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2. PRO MATE programs the selected options on the microcontroller
device inserted in the socket.

3. PRO MATE performs a check of the selected options to verify the
information programmed into the microcontroller device and returns the
results of the verification. Although you can also select Verify manually,
the Verify option takes place every time a device is programmed.

Verifying a Microcontroller Device
You can choose to verify the contents of the target device manually by 
selecting Verify from the Program/Verify dialog.

Checking for a Blank Device
The PRO MATE checks the microcontroller device to verify that all program 
locations contain ones (the erased state). This is done automatically before a 
device is programmed, or can be done manually by selecting Blank Check All 
from the pull-down menu.

Reading a Device Master
PRO MATE reads the microcontroller device contents and copies the 
information into MPLAB’s Program Memory window and Programmer Status 
dialog.

Figure 3.6:  Read Device Dialog 

The Read Device dialog is just like the top half of the Program/Verify dialog. 
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Program Memory and PRO MATE
For MPLAB, Program Memory can mean various things. When in the 
PICMASTER emulator mode, Program Memory shows the data that is in the 
emulation memory of the PICMASTER pod. This memory is read by the 
PICMASTER probe when you run, single step, or trace using the emulator. 
When in the simulator mode, the Program Memory window reflects memory as 
seen by MPLAB-SIM. This memory is read by MPLAB-SIM when you run, 
single step, or trace.

When you are using PRO MATE, the Program Memory window also 
represents data that is to be programmed into the target device inserted into 
PRO MATE, or represents data that has been read from the target device.

If you read memory from PRO MATE while in emulator or simulator mode, the 
emulator or simulator program memory will be overwritten.

Because of these various uses of the Program Memory window, you should be 
aware of potential “mis-matches” if you read data from a target device while 
you have an MPLAB project open. Debug operations may not work properly, 
and data in other windows may not match the newly read data from 
PRO MATE.

Figure 3.7:  Program Memory Window

You can view the Program Memory in hex, machine code, or disassembler 
with symbols (if available).
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Running PRO MATE from the DOS Command Line
Invoke PRO MATE software from the PC Host with the following command:

PROCMD <options>

The following command line options are available.

If you should enter an invalid parameter a minimal error message will be 
shown. Test the returned error code in your batch program to determine the 
error. The error codes are

Command Syntax

Download firmware /d<filename>

Target hex file /f<filename>

SQTP file /s<filename>

Device /p<partname>

Comm port /<number>

VDD Max /x<voltage>

VDD Min /n<voltage>

VPP /v<voltage>

Enable Safe Mode /r

Program /m

ERRORLEVEL Value Description

0 Success

1 PRO MATE not found

2 Wrong socket module

3 File not found

4 Illegal device specified

5 Illegal voltage specified 

6 Program/verification error

7 Download firmware must be done independently 

8 Illegal parameter

9 Illegal hex file

10 Illegal SQTP file

255 Other error
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Serial Communications Port

Firmware File Name

Target Hex File

Program

Part Name

Safe Mode

SQTP File

/# Serial Port Selection where # = <1|2|3|4>. Valid serial ports 
are COM1 through COM4. The default serial port is COM1. 

/d<file> Firmware File Name Selection. The /d argument selects the 
*.HEX firmware program file that PRO MATE uses in its 
internal firmware. This will download the specified file from the 
PC. Refer to the latest README.PRO text file that 
accompanied the most recent version of software for the 
names of the current firmware file. 

/f<file> Target Hex File Name Selection. The /f argument selects the 
*.HEX firmware program file that PRO MATE will program into 
the device. The host software accepts the absolute file name 
as well as the relative file name (with respect to the working 
directory). 

/m Program the current device in the PRO MATE programming 
socket.

/p<part> Part Name Selection. The string match is case insensitive. 
Refer to the most current README.PRO file for a list of the 
available devices.
Enter the suffix of the part name. For example, for the 
PIC16C54 device, enter PIC16C54. Please be very careful to 
enter the exact part number in order to select the 
programming algorithm for the device you are programming.

/r Safe/Restricted Mode. This mode is intended to protect 
against inadvertent modification of a master file by disabling 
most commands (including Read and Edit) while still allowing 
execution of the Program, Verify, and Blank Check 
commands.

/s<file> Enable SQTP mode and set the SQTP file name.
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VDD Max

VDD Min

VPP

Command Line Examples: 

procmd  /d  PM400000.HEX
procmd /1 /Fmyfile.hex /PIC16C54 /m
procmd /3 /Fd:\mydir\myfile.hex /P16C54 /m

Upgrading PRO MATE Firmware and Host Software
PRO MATE’s modular design allows Microchip Technology to easily upgrade 
PRO MATE firmware and host software to support new devices as the devices 
become available. 

PRO MATE Version Numbers
Select Help>About to display the current software version information. 

MPLAB Software: The current version of the PC Integrated 
Development Environment software.

PRO MATE Software: The current version of the MPLAB PRO MATE 
software driver that is used on the PC

MPLAB Software Version
MPLAB is updated on a regular basis to provide support for new features and 
to support simulation of new processors. Usually the MPLAB software must be 
used with a specific version of PRO MATE PC software. 

PRO MATE PC Software
The PRO MATE PC Software is the software that is installed into MPLAB to 
control the PRO MATE. This software has a version different from MPLAB and 
can be seen in the Help>About box.

/x Set the VDD programming voltage on the device to be 
programmed to a maximum value. Enter as four digits. To set 
it to a value of 5.75 volts:
/x0575

/x Set the VDD voltage on the device to be programmed to 
minimum value. Enter as four digits. To set it to a value of 4.00 
volts:
/x0400

/v Set the VPP programming voltage value. Enter as four digits. 
To set it to a value of 13.25 volts:
/x1325
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PRO MATE Firmware Version
To see which firmware version is loaded in your device programmer, turn the 
device programmer off and back on and read the version from the second 
display. If have more current firmware files you should upgrade the device 
programmer firmware. Refer to “Updating Firmware” in Chapter 4 for 
additional information.

Version Number Compatibility Check
Every time the PRO MATE host software runs, compatibility checks are made 
with MPLAB.  If there is an incompatibility, a message box will inform you of 
the version required.

When you select devices from the Programmer Status window, you will be 
informed if the firmware version does not support that device. Refer to 
“Updating Firmware” in Chapter 4 for information on downloading firmware.

Files Used by PRO MATE 
PRO MATE can use information directly from MPLAB projects without any 
intermediate steps. MPASM can be used separately from MPLAB to produce 
hex files for PRO MATE. Alternatively, devices can be programmed with hex 
files from any PICmicro microcontroller compatible cross-assembler or cross-
compiler.

If you are using MPASM separate from MPLAB, or are generating hex files 
from within MPLAB for use later with PRO MATE, you should use either 
INHX8M or INHX32 hex formats. MPASM’s default output format for hex files 
is INHX8M. If you are programming PIC17CXX devices, you should use 
INHX32 format. See MPASM User’s Guide or MPLAB’s on-line help for 
MPASM for details on file formats.
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Chapter 4.   Using PRO MATE
Introduction 
This chapter will cover the basic operation of the PRO MATE device 
programmer. This will cover the main steps for programming and reading a 
device.

Highlights
This chapter covers these topics:

• Preliminary Requirements

• Accessing MPLAB Tools and Menu Functions

• Loading PICmicro Hex Code

• Checking For a Blank Device

• Programming a Device

• Reading a Device Master       

• Using Serial Programming

• Using Hexadecimal Record Formats

• Changing Voltage Settings

• Updating Firmware

Preliminary Requirements
Make sure that you have gone through the hardware and software installation 
procedures as described in Chapter 2: PRO MATE Installation . You should 
have the PRO MATE device programmer connected to the PC with a cable to 
your serial port, and MPLAB should be communicating with PRO MATE as 
described in Chapter 3: PRO MATE Basic Functions .

You should have an unprogrammed PICmicro device to use in this tutorial, and 
you should have some code to use, either in the form of a hex file, or as a 
source text file which can be built using an MPLAB project.

Accessing MPLAB Tools and Menu Functions
MPLAB functions are accessed from standard Windows 3.1 style pull down 
menus. The MPLAB menus are discussed at length in the MPLAB User’s 
Guide. You can take the time to learn about MPLAB Projects and use the 
editor and simulator to write and debug your code if you wish.

If you already have your code finished, or prefer not to use the MPLAB IDE, 
you can simply use MPLAB as host software to import your code and control 
PRO MATE. You will not need to read the MPLAB manual to use PRO MATE.
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Loading PICmicro Hex Code
Using PRO MATE without MPLAB Projects
If you have a .HEX file ready for programming into a PICmicro microcontroller, 
select File>Import>Download to Memory to load your code into the MPLAB 
Program Memory window. 

Using PRO MATE with MPLAB Projects
If you have read the MPLAB User’s Guide and are building your firmware 
code using an MPLAB project, code shown in the Program Memory 
window can be directly programmed into the PICmicro device. 

If you have configuration bits set in your source code, then every time you re-
build your project, the configuration bits shown in Programmer Status dialog 
will be updated with those values. If you do not set configuration bits in your 
source code, then these bits will not be changed. You can manually change 
them from their default values and they will be programmed into the PICmicro 
device when you program the microcontroller.

Figure 4.1:  Programmer Status Dialog

You may change the device type for the programmer by selecting a new 
device.
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Checking For a Blank Device
You can select PRO MATE>Blank Check All  to verify that a device is 
completely erased (all bits are set to a "1"). This will also verify that all 
configuration bits are set to a "1" (unprogrammed) state.

Figure 4.2:  Blank Check Result
If you are using an OTP (one-time programmable) part, some configuration 
bits may be already programmed from the factory (oscillator bits, for instance). 
In that case you should set the configuration bits in the Programmer Status 
dialog to the factory settings and select PRO MATE>Blank Check OTP. This 
will check that all program memory bits are set to one’s, and that the 
configuration bits match the values in the Programmer Status dialog (Watch 
Dog Timer, Oscillator, etc.).

Figure 4.3:  Blank Check OTP Result
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Programming a Device
Make sure that the device as shown on MPLAB’s Programmer Status dialog is 
the same as the device you are ready to program. 

Insert a device to be programmed into the PRO MATE socket. Position pin one 
on the device to be in the pin one position as shown on the diagram next to the 
socket.

Figure 4.4:  Program/Verify Dialog

Select PRO MATE>Program/Verify  to bring up the Program/Verify dialog.

Ensure that the address range is correct and that the appropriate options are 
checked.

Click Program, and PRO MATE will program the data into your device. 
PRO MATE will immediately verify that the device was correctly programmed.

Reading a Device Master
If you want to copy the data from a programmed PICmicro device into an 
unprogrammed device, you can select PRO MATE>Read Device to bring up 
the Read Device dialog. Leave the settings at their default state to read all of 
memory into MPLAB. Click Read.
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Figure 4.5:  Read Dialog

The Program Memory window will now show you the data read from the device 
master, and you can then save that data as a hex file, insert a new device into 
PRO MATE to copy that same data into a new device, or modify the data in 
MPLAB before you save or program another device.

Using Serial Programming
Serialization allows you to program a serial number into each microcontroller 
device that the Device Programmer programs. Serialization is done by using a 
series of RETLW (Return Literal W) instructions, with the serial number bytes 
as the literal data. To serialize, you must first generate a serialization file, and 
then use that file to serialize locations in the device microcontroller. 

Note: Code protected devices can not be copied.
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Generate SQTP File
Select PRO MATE > Generate SQTP File to display a dialog box for 
generating an SQTP file. Fill in the appropriate values for the type of SQTP file 
you are generating, then click Generate. For example, an SQTP file for a 
PIC16C5X device might be generated as shown:  

Figure 4.6:  Sample Serial SQTP File

Refer to ”Using Hexadecimal Record Formats” in this chapter for more 
information on the format of SQTP files.

Serialization On
Click SQTP File from the Programmer Status dialog and select a file to enable 
serialization for the current programming session.

When serialization is enabled, the serial number that will be programmed into 
the next device can be seen in its appropriate location in the Program Memory 
Window.

Programming SQTP Devices
To program a device with the SQTP information, simply enable SQTP and 
program the device normally. After the device is programmed, the Program 
Memory Window will display the next serial number. If the last serial number in 
the file was used, a message will appear and serialization will be disabled.

When a serial number is used, the SQTP file is marked by replacing the colon 
for that entry by a semicolon. This allows you to use the same SQTP file over 
multiple programming sessions without repeating any numbers.
DS30082G- page 28 ”  1997 Microchip Technology Inc.



Chapter 4. Using PRO MATE
Using Hexadecimal Record Formats
The following hexadecimal record format discussion provides the proper file 
format for the PICmicro device families. Make sure your assembler or compiler 
is configured to generate hex files in the proper format. 

PRO MATE uses the formats described in the following paragraphs as follows:   

Each hexadecimal data record has the following format:

INHX8M

The data record is output as described above.

INHX32

The extended linear address record is output to establish upper 16 bits of data 
address.

PIC16C5X/6X Uses INHX8M

PIC17CXX Uses INHX32

Firmware Downloads Uses INHX32

:BBAAAATTHHHH....HHCC

: Start Character (prefix)

BB Two-Digit Byte Count specifying 
number of data blocks in record

AAAA Four-Digit Starting Address of data 
record

TT Two-Digit Record Type

00 = Data Record

01 = End-of-File Record

02 = Segment Address Record

04 = Extended Linear Address 
Record (INHX32)

HHHH....HH Two-Digit Data Blocks

CC Two-Digit Checksum—Two’s 
complement of sum of all preceding 
bytes in data record except the colon.
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Changing Voltage Settings
Change voltage settings only if your application runs at the extreme voltage 
operating range. Most users will never need to change the default voltage 
settings. 

• VDD Max and VDD Min are the voltages at which programmed 
microcontroller devices will be verified. 

• VPP is the voltage at which microcontroller devices will be programmed. 

The Programmer Status Window always displays the current voltage settings. 
To change a voltage, select it from the pull down list next to each setting. 
Choose the desired VDD minimum, maximum, or VPP voltage value. 

Updating Firmware
Update your firmware when you receive a firmware upgrade, or when the 
EEPROM in the Device Programmer needs to be reprogrammed. The 
EEPROM needs to be reprogrammed if the message “Ready for Download” 
appears at power-up on the LCD Display.

PRO MATE firmware is downloaded as follows:

From the PRO MATE Device Programmer:

1. While powering on the device programmer, simultaneously press 
F1 and F3 to select “Ready for Download...”. (You may also use the
PRO MATE Utilities menu to access “Ready for Download.”)

2. The Device Programmer displays “Ready for Download.”

From MPLAB

1. Start up the MPLAB software. 

2. Select PRO MATE > Download Firmware from the menu bar.

3. Select the current firmware version to download to PRO MATE. 

4. Verify that the device programmer is ready for download and click OK.

Note: The voltage range and default voltage setting may be different for 
each microcontroller device type. Refer to the PRO MATE Device 
Support document for voltage values for specific devices.

Voltage Settings

Selection Default Voltage Value

VDD Min (3.00 .. 6.00) 3.00

VDD Max (3.00 .. 6.00) 6.00

VPP (12.5 .. 13.5) 13.25
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5. “Downloading to PRO MATE” displays on the PC monitor and on the
Device Programmer. The Device Programmer also displays an activity
indicator in the last location of the second line. Downloading may take a
couple of minutes. 

6. The device programmer perform a calibration when download is
complete. This will take approximately 30 seconds.

7. “Complete! Press a key to begin” appears on the PRO MATE display.
Press one of the four PRO MATE buttons to continue. The PRO MATE
II does not require a button to be pressed.
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NOTES:
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Chapter 5.   Stand-Alone Mode
Introduction
This chapter contains a description of the PRO MATE device programmer 
menus and commands. The device programmer provides a user friendly 
interface that gives you complete control over a programming session.

Highlights
The highlighted points in this chapter are:

• Stand-Alone Mode

• PRO MATE Start-Up

• Command Menu 

• Utilities Menu

Stand-Alone Mode
Stand-Alone mode allows you to read, program, and verify a device without 
using a PC. Stand-Alone mode is useful in situations where a PC may not be 
available or even required, such as in the field or in a lab production 
environment. To use the device programmer, you must have a socket module 
installed.

Socket Module
When you power up the PRO MATE device programmer, the unit 
automatically detects the type of socket module installed and initializes the 
PRO MATE function buttons, F1 - F4. The device programmer then displays 
the device options that you can choose from for the currently installed socket 
module. You must install a new socket module prior to selecting a device not 
supported by the current socket module. If you power on the device 
programmer without a valid socket module installed, the unit displays the 
message “Socket Not Supported.”       

Caution: Ensure the device programmer is powered OFF before changing 
a socket module.

Caution: Do not power up the PRO MATE with a device loaded in the 
socket. Damage to the device or PRO MATE may result.
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LCD Display
In Stand-Alone mode, the PRO MATE device programmer communicates with 
the user through a two-line by 20 character LCD display. The top line of the 
LCD displays status and error message information. The bottom line of the 
LCD displays command options. The displayed commands are spaced to 
correspond to the F1 through F4 function buttons. To execute a specific 
command, press the appropriate function button.

PRO MATE Start-Up
After applying power to PRO MATE, the unit displays the product title and 
version number. The PRO MATE firmware then attempts to identify the 
currently installed socket and displays the socket module name if the socket 
module is recognized. 

PRO MATE next displays a device selection menu. Select the desired device 
from the selection menu. After selecting a device, PRO MATE displays the 
Command menu.

Figure 5.1:  Start-Up/Utilities Menu Tree – PIC16C5X Shown

Start-Up Main Power-On 
with F1 and F2 pressed

Start-Up

SelectMain

Command 
Menu

Main

Start-Up
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54 54A 55 more
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Socket Module
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Device
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*PRO MATE II Only

Safe
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 Command Menu
After you select a device, the device programmer displays the Command 
menu. The functions on the Command Menu allow you to perform the basic 
user tasks for programming a microcontroller device: Program, Verify, and 
Read.
 

Figure 5.2:  Command Menu

Program    (Pgm, F1)
This command programs the device in the socket module with the contents of 
the internal memory of the device programmer. 

The device programmer checks to see if the installed microcontroller device is 
blank. If the device is not blank, the device programmer asks if you want to 
continue. Answer “Yes” to continue. Answer “No” to return to the Command 
menu.

The device programmer programs the contents of its memory into the 
microcontroller device loaded in the socket module.

After programming a device without errors, the device programmer performs a 
check to verify the data programmed into the device, and returns the results of 
the verification. For the installed device, the device programmer performs the 
verification at the VDD Minimum and VDD Maximum voltages.

The device programmer reports programming errors and verify errors 
according to where the error occurred. Errors are reported for program, 
configuration bits, and ID locations.

After programming, the device programmer displays the checksum.

PIC16C54
Read  Pgm   Vfy  main

F1 F2 F3 F4
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Figure 5.3:  Program Menu Tree—PIC16C5X Shown

Verify   (Vfy, F2)
The device programmer compares the contents of its internal memory to the 
contents of the programmed microcontroller device loaded in the socket 
module. If the data and configuration bit settings are correct, “VERIFIED” will 
display on the LCD. The device programmer performs the verification at the 
VDD Minimum and VDD Maximum voltages. The device programmer reports 
errors according to which part of the device failed.

Command Menu

Command Menu

Command Menu

Command Menu Command Menu Command Menu

PIC16C54
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 The Verify function also confirms that erased parts are blank. If all 
programmable locations are blank for a device loaded in the socket module, 
the device programmer displays ERASED. Reported results include the 
following:

• Same Contents

• Blank Device

• Errors

Figure 5.4:  Verify Menu Tree—PIC16C5X Shown

Read   (Read, F3)
Press Read to copy the contents of the device in the socket module into the 
internal memory of the device programmer. 

For PIC16CXX devices, the device programmer will ask the question: “Code 
Protect Parts?” Answer “Yes” to code protect the parts that you will be 
programming. Code protection will remain effective until a new device is read. 
Answer “No” to program devices exactly as read.

After reading a device, the device programmer displays a checksum. If the 
device is code protected, a code protection message will be displayed prior to 
the read. Answer “Yes” to continue. Answer “No” to return to the Command 
menu.

PIC16C54
Pgm  Vfy  Read Main

Checking...........

Mem Fail  XXXXXXXXX
Press a Key to Cont.

Cnfg Fail  XXXXXXXXX
Press a Key to Cont.

ID Fail  ID=NNNN
Press a Key to Cont.

Verified! Csum=NNNN

Command MenuCommand Menu

Command Menu

Command MenuCommand Menu

where XXXXXXXXX
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ID=NNNN or
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Figure 5.5:  Read Menu Tree – PIC16C5X Shown

Main (Main, F4)
Returns to the Main menu.

Utilities Menu
 

Figure 5.6:  Stand-Alone Utilities Menu

Calibrate   (Cal, F1)

Performs a calibration on the PRO MATE device programmer.

Command Menu

Command Menu

Command Menu

Reading...........

Reading...........

Code Protect Parts??
Continue ??  Yes No

Csum=NNNN   ID=NNNN

Firmware
Sets Code

Protect On

Code
Protected

Part Code Protected!
Continue ??  Yes No

PIC16C54
Pgm  Vfy  Read Main

No Yes

PRO MATE Utilities
Cal  Dwnld   LCD  Cncl

F1 F2 F3 F4
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Calibrates the internal voltage generators (VDD and VPP). After calibration is 
complete, the device programmer displays:  

Figure 5.7:        Calibration Complete Message         

Download   (Dwnld, F2)
Sets up the device programmer for downloading new firmware.

Press Dwnld to Download new firmware into the onboard memory. “Ready for 
Download” displays after pressing Dwnld.    

Figure 5.8:  Ready for Download Message

After this message displays, execute the download command from MPLAB 
menu, PRO MATE > Download Firmware. When downloading starts, the LCD 
will show “Downloading from PC...,” and an activity indicator will display on the 
last location of the second display line. Refer to Updating Firmware in 
Chapter 6 for additional downloading information.

To exit Download, wait until download is completed, or turn the device 
programmer off.     

Complete!!
Press a key to begin

Note: In a production environment, calibrate the device programmer 
each week. Also calibrate the device programmer after changing 
the power supply.

Caution: Do not have a device installed in the socket module when 
calibrating the device programmer. Applied voltages will exceed 
the maximum ratings of all parts, and will damage the installed 
device.

Ready for Download..

Note: The device programmer performs a calibration after each 
download.
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LCD Contrast Adjust   (LCD, F3)
The Contrast Adjust control (available with PRO MATE II hardware only) 
allows you to make the LCD display lighter or darker. Press Light to make the 
LCD display lighter. Press Dark to make the LCD display darker. Press Done 
when finished.     

Figure 5.9:   Contrast Adjust Message

Contrast Adjust
Light     Dark  Done
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Chapter 6.   PRO MATE Menu Options
Introduction
This chapter covers all of the PRO MATE menu items on the MPLAB 
Integrated Development Environment, and details the PRO MATE dialogs that 
control device programming, reading, and verifying. 

PRO MATE Menu

Enable/Disable Programmer
This selection will enable or disable the PRO MATE operation. When 
PRO MATE >Enable Programmer is selected, MPLAB will attempt to establish 
communications with the PRO MATE. You will get an error message if the 
COM port is not set correctly, if the PRO MATE is not hooked up, or if the PRO 
MATE power supply is not connected.

Figure 6.1:  PRO MATE Pull Down Menus
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If you do not establish communications at first, you can correct the problem 
and reselect the menu option to try to again initialize the communications 
between MPLAB and PRO MATE.

Program/Verify
Once communications are set up and you have selected the target 
device, you can either load your code from a .HEX file with 
File>Import>Download To Memory  or directly from your recently built project. 
In both cases, the code will be shown in MPLAB’s Program Memory window.

Select PRO MATE>Program/Verify  to bring up the Program/Verify dialog. 
From this dialog, you can either program the data as shown in MPLAB’s 
Program Memory window, or verify that the data in the device in the 
PRO MATE socket matches data in MPLAB’s Program Memory window.

Figure 6.2:  Program/Verify Dialog 

Using the check boxes on the Program/Verify dialog, you can select to 
program or verify only the program memory or other memory areas on the 
target device.   

The Start Address and End Address will default to the start and end addresses 
of program memory on the selected device. You can change this to a smaller 
area by changing the addresses in these boxes.

Read Device
When you select PRO MATE>Read Device, the Read Device dialog will 
appear on your screen. Like the Program/Verify, you can set the program 
memory range and the other read options.
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Figure 6.3:  Read Device Dialog

After reading a device into MPLAB, its data will appear in the Program Memory 
window. Data can be changed using the Modify dialog, and it can be saved it 
to a hex file with File>Export>Save Hex File.

Figure 6.4:  Save Hex File Dialog

If you have a PICMASTER® emulator connected to MPLAB, your code will be 
downloaded to the emulated program memory of the PICMASTER. If you have 
a project open be aware that the Absolute Listing window and the Source 
window may not match the data you have read into the Program Memory 
window. Symbols may not match the proper addresses in the Program 
Memory window, and code in the PICMASTER’s memory, as shown in the 
Program Memory window, may be different than code shown in the Absolute 
Listing window. 
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Figure 6.5:  Program Memory Window

Blank Check All
You can select PRO MATE>Blank Check All  to verify that a device is 
completely erased (all bits are set to a "1"). This will also verify that all 
configuration bits are set to a "1" (unprogrammed) state.

Figure 6.6:  Blank Check All Result

If you are using an OTP part, some configuration bits may be already 
programmed from the factory (oscillator bits, for instance). In that case you 
should use PRO MATE>Blank Check OTP. 

Blank Check OTP
If you are using an OTP part, some configuration bits may already be  
programmed from the factory (oscillator bits, for instance). In that case you 
should set the configuration bits in the Programmer Status Dialog to the 
factory programmed settings and select PRO MATE>Blank Check OTP.  This 
will check that all program memory bits are set to one’s, and that the 
configuration bits match the value in the Programmer Status dialog
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Figure 6.7:  Blank Check OTP Result

Display Error Log
When you have programmed a device or verified a device, an error window will 
show you data from memory in the device that do not match the corresponding 
memory in MPLAB.
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Figure 6.8:  Sample Error Log Dialog

Erase Program Memory
This will set all bits in program memory, data memory and calibration memory 
window to ones.

Erase Configuration Bits
This option will set all available configuration bits and ID location bits to ones, 
their un-programmed state. If you then reload your hex file which has 
configuration data or if you rebuild your project which has configuration bits 
defined, these values will change in the Programmer Status dialog. You can 
use this to override the values in your code by selecting this after you have 
loaded your hex file or rebuilt your project.

Reset Voltages
This option sets VDD Min, VDD Max, and VPP to their default values for the 
selected device.

Transfer to PRO MATE
This option transfers all device and voltage information from MPLAB to the 
PRO MATE Device Prigrammer.

Transfer from PRO MATE
This option transfers all device and voltage information from the PRO MATE 
Device Programmer to MPLAB.
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Generate SQTP File
This option generates a file that can be used for device serialization. Refer to 
Chapter 4: Using PRO MATE, “Using Serial Programming,” for more 
information.

Load SQTP File
This option includes serial programming and selects serialization file. It is 
identical to clicking SQTP File on the Programmer Status dialog. Refer to 
Chapter 4: Using PRO MATE, “Using Serial Programming,” for more 
information.

Download Firmware
This option downloads firmware to the PRO MATE Device Programmer. Refer 
to Chapter 4: Using PRO MATE, “Updating Firmware,” for more information.

Establish Communications
This re-establishes RS-232 communications with the device programmer. Use 
this if power has been disconnected from the PRO MATE. This does not reset 
programming information in the Programmer Status Dialog, configuration bits 
or IDs.

Options>Programmer Options Menu

Communications Port Setup
The Communications Port Setup Dialog shows the possible PC serial 
communication ports. 

Figure 6.9:  Communications Port Setup Dialog

OK sets the options. Cancel will ignore the changes and close the dialog.
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Select Programmer
If you use other device programmers with MPLAB, only one can be 
enabled at a time.  To change the active device programmer, select 
Options>Programmer Options>Select Programmer.  Choose the desired 
programmer from the pull down list and click on OK.

Note that MPLAB must be restarted after the device programmer has been 
changed. 

Figure 6.10:  Select Programmer Dialog
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Chapter 7.   Migrating from Earlier PRO MATE Systems
If you have used previous Microchip PRO MATE development systems, 
you should find MPLAB PRO MATE to be easy to use. Install MPLAB 
as described in Chapter 2: PRO MATE Installation, “PRO MATE Installation.” 
If you already have 
the serial cable installed, set the COM port from MPLAB’s 
Options>Programmer Options>Communications Port Setup menu.

Figure 7.1:  Programmer Setup Dialog Box

MPLAB offers you new features, such as:

• Disassembly of code read from target devices

• Save code as instructions so that you can generate source files

• Quickly program code from MPLAB projects

• Directly read code from a device in PRO MATE to the MPLAB-SIM 
simulator debugger, or to PICMASTER emulation memory for real-time 
debugging
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NOTES:
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Appendix A.   Troubleshooting
Introduction
The troubleshooting information in this chapter can help you resolve typical 
problems or obstacles in programming microcontroller devices.

Highlights
The troubleshooting information in this chapter includes:

• Troubleshooting Hardware

– Calibration
– Communication Failure
– Ensuring Proper Socket Module Contact
– Socket Module Alignment
– Socket Module Failure 

• Troubleshooting Operation Type Problems

– Device Selection in Stand-Alone Mode
– Reading a Device Master in Stand-Alone Mode
– Unstable EEPROM in Device Programmer
– Device Pin Damage

• Troubleshooting Software

– Establishing Communication with PRO MATE
– Default Serial Port

Troubleshooting Hardware

Calibration
An internal hardware problem could prevent proper calibration. If you receive 
the message “Calibration Error!” on the Device Programmer, contact your 
Microchip Sales Office for further instructions. 

Communication Failure
The following table gives the data for connecting the PRO MATE Device 
Programmer to a 25-pin serial port. Connect the corresponding terminals on 
each line of the table. If communication fails, check your PC serial port. 

Table A. 1:  PC HOST TO PRO MATE SIGNALS 

25-Pin 
Female 

(PC Host)
9-Pin 

Male 
(PRO MATE)

2 TX 3 RX
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Ensuring Proper Socket Module Contact
After changing a socket, insert a blank device and do a blank check (Vfy/F2 on 
the Device Programmer) to insure the socket is making proper contact. A 
blank device will show erased.

Socket Module Alignment
After tightening the socket module screws, power on the Device Programmer. 
If the LCD display shows any of the following messages, power off the Device 
Programmer and realign the socket module:

– Align socket bottom
– Align socket top
– Select socket
– Socket not known

Socket Module Failure
If you can program a master chip, and if you can read and try to program code 
protected chips, but the chips fail the programming attempts, then potential 
socket pin damage may be the cause of the problem. 

Contact your FAE if your socket module is not operating properly.

Troubleshooting Operational Problems
Device Selection in Stand-Alone Mode

When you power up the Device Programmer, the unit will automatically detect 
the type of socket module installed and determine the device(s) for the 
installed socket module. A new socket module must be installed prior to 
selecting a new device type. 

Reading a Device Master in Stand-Alone Mode

When reading a device master in stand-alone mode, the Device Programmer 
asks the question: “Code Protect Parts” being programmed. Answer Yes to 
code protect the parts that you will be programming.

3 RX 2 TX

20 DTR 4 Data Ready

7 Ground 5 Ground

6 DSR 6 +5 volts

4 RTS 7 CTS

5 CTS 8 RTS

Table A. 1:  PC HOST TO PRO MATE SIGNALS  (Continued)

25-Pin 
Female 

(PC Host)
9-Pin 

Male 
(PRO MATE)
DS30082G- page 52 ”  1997 Microchip Technology Inc.



Appendix A. Troubleshooting
Unstable EEPROM in Device Programmer

Update your firmware when you receive a firmware upgrade, or when the 
contents of the EEPROM in the Device Programmer is damaged. The 
EEPROM contents is damaged if the message, “Ready for Download” 
appears on the LCD Display at normal power-up.

Device Pin Damage

On the smaller device packages (SSOP, PQFP, and SOIC) the pins can bend 
easily and give problems in programming the devices.

Troubleshooting Software
Establishing Communication with PRO MATE

MPLAB attempts to establish communication with the PRO MATE device 
programmer upon enabling the programmer. If communication cannot be 
established, no programming can occur. A dialog box appears if the attempt to 
establish communication fails. If a communication attempt fails, try again after 
correcting the problem, or cancel.

If you encounter communications problems, try the following:

1. Make sure that the RS-232 cable is connected, the power supply is
connected, and the Power LED on the PRO MATE is on.

2. Make sure that a COM port is properly set up exclusively for use by
PRO MATE.

Windows Users: A serial mouse will use a COM port, as will an external
modem. An internal modem has its own COM port, so if you have a
second COM port on your PC, set it so it won’t conflict with either the
mouse or the modem.

Win 95 Users: Note that Win 95 requires special attention to setting up
COM ports. Check your computer BIOS settings to make sure that your
board has an available COM port. A serial mouse will use a COM port,
and an external modem will, tool. An internal modem has its own COM
port, so if you have a second COM port on your PC, set it so it won’t
conflict with either the mouse or the modem. Check the Ports (COM &
LPT) under the System settings in the Control Panel. Check their
Properties>Resources to ensure they are operating properly and that
there are no conflicts. 

On some systems, it is also necessary to manually set the COM port to
hardware handshaking. Disable the FIFO as well if problems persist.

Default Serial Port

PRO MATE uses COM1 as the default serial port the first time you 
run PRO MATE. If you change your serial port selection with the 
Options>Programmer Options > Communications Port Setup command, 
then the next time you run PRO MATE, the host software will use the same 
serial port used in the previous session. 
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Appendix B.   On-Line Support
Introduction
Microchip provides two methods of on-line support. These are the Microchip 
BBS and the Microchip World Wide Web (WWW) site.

Use Microchip’s Bulletin Board Service (BBS) to get current information and 
help about Microchip products. Microchip provides the BBS communication 
channel for you to use in extending your technical staff with microcontroller 
and memory experts.

To provide you with the most responsive service possible, the Microchip 
systems team monitors the BBS, posts the latest component data and 
software tool updates, provides technical help and embedded systems 
insights, and discusses how Microchip products provide project solutions. 

The web site, like the BBS, is used by Microchip as a means to make files and 
information easily available to customers. To view the site, the user must have 
access to the Internet and a web browser, such as Netscape or Microsoft 
Explorer. Files are also available for FTP download from our FTP site.

Connecting to the Microchip Internet Web Site
The Microchip web site is available by using your favorite Internet browser to 
attach to:

www.microchip.com

The file transfer site is available by using an FTP service to connect to:

ftp://ftp.futureone.com/pub/microchip

The web site and file transfer site provide a variety of services. Users may 
download files for the latest Development Tools, Datasheets, Application 
Notes, User’s Guides, Articles and Sample Programs.

A variety of Microchip specific business information is also available, including 
listings of Microchip sales offices, distributors and factory representatives. 
Other data available for consideration is:

• Latest Microchip Press Releases

• Technical Support Section with Frequently Asked Questions

• Design Tips

• Device Errata

• Job Postings

• Microchip Consultant Program Member Listing

• Links to other useful web sites related to Microchip Products
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Connecting to the Microchip BBS
Connect worldwide to the Microchip BBS using either the Internet or the 
CompuServe“  communications network. 

Internet: You can telnet or ftp to the Microchip BBS at the address 
mchipbbs.microchip.com

CompuServe Communications Network: In most cases, a local call is your 
only expense. The Microchip BBS connection does not use 
CompuServe membership services, therefore 

You do not need CompuServe membership to join Microchip’s BBS.

There is no charge  for connecting to the BBS, except for a toll charge to the 
CompuServe access number, where applicable. You do not need to be a 
CompuServe member to take advantage of this connection (you never actually 
log in to CompuServe).

The procedure to connect will vary slightly from country to country. Please 
check with your local CompuServe agent for details if you have a problem. 
CompuServe service allow multiple users at baud rates up to 14400 bps.

The following connect procedure applies in most locations.

1. Set your modem to 8-bit, No parity, and One stop (8N1). This is not the
normal CompuServe setting which is 7E1.

2. Dial your local CompuServe access number.

3. Depress <Enter ø> and a garbage string will appear because
CompuServe is expecting a 7E1 setting.

4. Type +, depress <Enterø> and Host Name: will appear.

5. Type MCHIPBBS, depress <Enterø> and you will be connected to the
Microchip BBS.

In the United States, to find the CompuServe phone number closest to you, 
set your modem to 7E1 and dial (800) 848-4480 for 300-2400 baud or 
(800) 331-7166 for 9600-14400 baud connection. After the system responds 
with Host Name:, type NETWORK, depress <Enterø> and follow 
CompuServe’s directions.

For voice information (or calling from overseas), you may call (614) 723-1550 
for your local CompuServe number.

Using the Bulletin Board
The bulletin board is a multifaceted tool. It can provide you with information on 
a number of different topics.

• Special Interest Groups

• Files

• Mail

• Bug Lists
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Special Interest Groups
Special Interest Groups, or SIGs as they are commonly referred to, provide 
you with the opportunity to discuss issues and topics of interest with others 
that share your interest or questions. SIGs may provide you with information 
not available by any other method because of the broad background of the 
PICmicro user community.

There are SIGs for most Microchip systems and device families. These groups 
are monitored by the Microchip staff.

Files
Microchip regularly uses the Microchip BBS to distribute technical information, 
application notes, source code, errata sheets, bug reports, and interim 
patches for Microchip systems software products. Users can contribute files 
for distribution on the BBS. For each SIG, a moderator monitors, scans, and 
approves or disapproves files submitted to the SIG. No executable files are 
accepted from the user community in general to limit the spread of computer 
viruses.

Mail
The BBS can be used to distribute mail to other users of the service. This is 
one way to get answers to your questions and problems from the Microchip 
staff, as well as keeping in touch with fellow Microchip users worldwide.

Consider mailing the moderator of your SIG, or the SYSOP, if you have ideas 
or questions about Microchip products, or the operation of the BBS.

Software Releases
Software products released by Microchip are referred to by version numbers. 
Version numbers use the form:

xx.yy.zz

Where xx is the major release number, yy is the minor number, and zz is the 
intermediate number.

Intermediate Release
Intermediate released software represents changes to a released software 
system and is designated as such by adding an intermediate number to the 
version number. Intermediate changes are represented by:

• Bug Fixes

• Special Releases

• Feature Experiments
”  1997 Microchip Technology Inc. DS30082G- page 57



MPLAB-PRO MATE USER’S GUIDE
Intermediate released software does not represent our most tested and stable 
software. Typically, it will not have been subject to a thorough and rigorous test 
suite, unlike production released versions. Therefore, users should use these 
versions with care, and only in cases where the features provided by an 
intermediate release are required.

Intermediate releases are primarily available through the BBS.

Production Release
Production released software is software shipped with tool products. Example 
products are PRO MATE, PICSTART, and PICMASTER. The Major number is 
advanced when significant feature enhancements are made to the product. 
The minor version number is advanced for maintenance fixes and minor 
enhancements. Production released software represents Microchip’s most 
stable and thoroughly tested software.

There will always be a period of time when the Production Released software 
is not reflected by products being shipped until stocks are rotated. You should 
always check the BBS or the WWW for the current production release.

Systems Information and Upgrade Hot Line
The Systems Information and Upgrade Line provides system users a listing 
of the latest versions of all of Microchip’s development systems software 
products. Plus, this line provides information on how customers can 
receive any currently available upgrade kits. The Hot Line Numbers are: 
1-800-755-2345 for U.S. and most of Canada, and 1-602-786-7302 for the rest 
of the world.

These phone numbers are also listed on the “Important Information” sheet that 
is shipped with all development systems. The hot line message is updated 
whenever a new software version is added to the Microchip BBS, or when a 
new upgrade kit becomes available.
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Beijing
Microchip Technology, Beijing 
Unit 915, 6 Chaoyangmen Bei Dajie 
Dong Erhuan Road, Dongcheng District 
New China Hong Kong Manhattan Building
Beijing 100027 PRC 
Tel: 86-10-85282100 Fax: 86-10-85282104
India
Microchip Technology Inc.
India Liaison Office
No. 6, Legacy, Convent Road
Bangalore 560 025, India
Tel: 91-80-229-0061 Fax: 91-80-229-0062
Japan
Microchip Technology Intl. Inc.
Benex S-1 6F
3-18-20, Shinyokohama
Kohoku-Ku, Yokohama-shi
Kanagawa 222-0033 Japan
Tel: 81-45-471- 6166  Fax: 81-45-471-6122
Korea
Microchip Technology Korea
168-1, Youngbo Bldg. 3 Floor
Samsung-Dong, Kangnam-Ku
Seoul, Korea
Tel: 82-2-554-7200  Fax: 82-2-558-5934
Shanghai
Microchip Technology 
RM 406 Shanghai Golden Bridge Bldg.
2077 Yan’an Road West, Hong Qiao District
Shanghai, PRC 200335
Tel: 86-21-6275-5700  Fax: 86 21-6275-5060  

ASIA/PACIFIC (continued)
Singapore
Microchip Technology Singapore Pte Ltd.
200 Middle Road
#07-02 Prime Centre
Singapore 188980
Tel:  65-334-8870  Fax: 65-334-8850
Taiwan, R.O.C
Microchip Technology Taiwan
10F-1C 207
Tung Hua North Road
Taipei, Taiwan, ROC
Tel: 886-2-2717-7175  Fax: 886-2-2545-0139

EUROPE
United Kingdom
Arizona Microchip Technology Ltd.
505 Eskdale Road
Winnersh Triangle
Wokingham 
Berkshire, England RG41 5TU
Tel: 44 118 921 5858 Fax: 44-118 921-5835
Denmark
Microchip Technology Denmark ApS
Regus Business Centre
Lautrup hoj 1-3
Ballerup DK-2750 Denmark
Tel: 45 4420 9895 Fax: 45 4420 9910
France
Arizona Microchip Technology SARL
Parc d’Activite du Moulin de Massy
43 Rue du Saule Trapu
Batiment A - ler Etage
91300 Massy, France
Tel: 33-1-69-53-63-20  Fax: 33-1-69-30-90-79
Germany
Arizona Microchip Technology GmbH
Gustav-Heinemann-Ring 125
D-81739 München, Germany
Tel: 49-89-627-144 0  Fax: 49-89-627-144-44
Italy
Arizona Microchip Technology SRL
Centro Direzionale Colleoni 
Palazzo Taurus 1 V. Le Colleoni 1
20041 Agrate Brianza
Milan, Italy 
Tel: 39-039-65791-1  Fax: 39-039-6899883
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WORLDWIDE SALES AND SERVICE

Microchip received QS-9000 quality system 
certification for its worldwide headquarters, 
design and wafer fabrication facilities in 
Chandler and Tempe, Arizona in July 1999. The 
Company’s quality system processes and 
procedures are QS-9000 compliant for its 
PICmicro® 8-bit MCUs, KEELOQ® code hopping 
devices, Serial EEPROMs and microperipheral 
products. In addition, Microchip’s quality 
system for the design and manufacture of 
development systems is ISO 9001 certified.
 1999 Microchip Technology Inc.
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